Information Technology Services

Drop Shadow

What web browsers can I use with Torero Mail?

Student Alumni

Starting August 1st 2011, you will need to use one of the following web browsers for accessing Torero Mail:

  • Microsoft Internet Explorer 8 or 9
  • Mozilla Firefox 3.6 or newer
  • Apple Safari 4 or newer
  • Google Chrome

Other web browsers might work (including web browsers on phones or game consoles), but they will not be supported by Google or USD.  You might experience slow speeds or a loss of functionality if you use an older browser.  For more information, please read Google's support document about Supported Web Browsers