Information Technology Services

Drop Shadow

"Application Blocked by Deployment Rule Set" error message


If you try and access any USD services that use Java (such as Kronos, Blackboard, Oracle, etc.) and you receive the error message, you might have an out of date version of Java installed.  Users with older versions of Java 7 will receive the message "Application Blocked by Deployment Rule Set: Deployment Rule Set required Java version SECURE-1.7 not available".



If you receive this message, you can install the latest version of USD's special Java installer by visiting - please log in with your MySanDiego username/Password.  If you still receive this message after installing the latest version of Java, please contact the ITS Help Desk at (619) 260-7900 for further support.